iOS 6 Compatablity

Skillz can be conditionally excluded at runtime in order to avoid incompatibilities with devices running iOS 6.
 
The two things that would need to be excluded are the initial call to skillzInitForGameId:environment in didFinishLaunchingWithOptions and any buttons you are using to launch Skillz.
 
There are few different ways to perform this version check. For example,
if (floor(NSFoundationVersionNumber) > NSFoundationVersionNumber_iOS_6_1) {
    // ios 7 only code (ie, Skillz)
}

Further examples can be found at http://stackoverflow.com/questions/3339722/how-to-check-ios-version.