Technical Requirements

iOS Requirements

Skillz for iOS requires the following:

  • Xcode 10.0 or later
  • Deployment target of 9.0 or later

Android Requirements

Skillz for Android requires the following:

  • Your game application must be compiled against Android API 19 or higher

Though not required for integration with Skillz, we strongly recommend the following:

  • Your game application is contained within an Android Studio 3.x+ project
  • Your game application uses the gradle build system

To see the Libraries Skillz uses, please check out the dependencies found in this file. If you need to use a Library already used by the Skillz SDK you must use the same version of that library. You can not override the version of any library used by Skillz.

Unity Requirements

 Skillz for Unity requires the following:

  • Unity 2018
  • Xcode 10 or later (when building games for iOS)
  • Android Studio 3.x+ (when building games for Android)

Note: At this time, we support development on Mac and cannot provide technical support for Windows development.