Requirements for Android

In order to integrate Skillz with your game, the following requirement must be adhered to:

  1. Your game application must be compiled against Android API 19 or higher.

Though not required for integration with Skillz, we strongly recommend the following:

  1. Your game application is contained within an Android Studio 3.0+ project
  2. Your game application uses the gradle build system

To see the Libraries Skillz uses, please check out the dependencies found in this file. If you need to use a Library already used by the Skillz SDK you must use the same version of that library. You can not override the version of any library used by Skillz.

This guide will assume all of the above when referencing path names and dependencies.